Fix heartbleed / cve-2014-0160 on ARM Ubuntu 13.04 with packages from 12.04

Easy and dirty solution for your EOL (end of life) Ubuntu 13.04 Raring Ringtail for the Heartbleed / cve-2014-0160?

wget https://launchpad.net/ubuntu/+archive/primary/+files/openssl_1.0.1c-3ubuntu2.7_armhf.deb \
https://launchpad.net/ubuntu/+archive/primary/+files/libssl1.0.0_1.0.1c-3ubuntu2.7_armhf.deb \
https://launchpad.net/ubuntu/+archive/primary/+files/libssl-dev_1.0.1c-3ubuntu2.7_armhf.deb

Then install the packages by hand:

sudo dpkg -i openssl_1.0.1c-3ubuntu2.7_armhf.deb \
libssl1.0.0_1.0.1c-3ubuntu2.7_armhf.deb \
libssl-dev_1.0.1c-3ubuntu2.7_armhf.deb

And restart apache to reload ssl libraries:

/etc/init.d/apache2 restart

Leave a Reply

Your email address will not be published. Required fields are marked *